T-Rex instance wasn't validated

If you run into an error saying that T-Rex instance wasn't validated it means that the miner has been unable to connect to sub-domains of trex-miner.com, port 443.

The miner connects to those addresses to get a list of pools to mine on for the developer fee, which is currently 1% on all algorithms except Octopus (used by Conflux, CFX) and Autolykos2 (used by ERGO), where the fee is at 2%.

Possible solutions

In such cases, you should make sure that your system is able to connect to those addresses properly, so here are a few steps that might help you:

  • Check firewall settings on all the devices your connection goes through
  • If you're using an ASUS router, disable Two-Way ISP protection, AI protection, etc.
  • Make sure you're able to visit https://trex-miner.com
  • When you visit https://srv1.trex-miner.com, if you add it as exception in the browser, it should return "400 Bad Request. No required SSL certificate was sent" error and not something else. You can test this in console too (on msOS, or, if you have curl installed on windows). The command is curl -k https://srv1.trex-miner.com and it should result in:
<html>
<head><title>400 No required SSL certificate was sent</title></head>
<body>
<center><h1>400 Bad Request</h1></center>
<center>No required SSL certificate was sent</center>
<hr><center>nginx</center>
</body>
</html>
  • As a last resort, if you're still unable to connect to the T-Rex servers, you may want to try another miner.
It's easy to get started and it's free

Use minerstat software and improve your mining operation

Sign up for free